Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: share/locale/monetary issue

Anders Lindgren wrote:-

> On Sat, 3 Jan 2009, Martin Husemann wrote:
>> On Sat, Jan 03, 2009 at 03:40:13PM +0200, Wojciech Galazka wrote:
>>> Output:
>>> dependall ===> share/locale/monetary
>>> nbmklocale: can't store db.
>> You can either update your build system to netbsd-4 latest (the fix for
>> libc has been pulled up yesterday) or update src/usr.bin/mklocale, which
>> has been changed to avoid this problem in another way.
> Hrrm I can't cross-build evbarm-current with sources as of noon CET today 
> on a 4.0.0_PATCH/amd64 from May 20, so the problem does not appear to be  
> fixable by updating the mklocale sources alone. At least not when I nuked 
> $tooldir/bin/nbmklocale and $objdir/usr/src/usr.bin/mklocale and rebuilt  
> with -u [...]. Does this mean the amd64 box will need a fresher  
> 4.0 for me to get any further?

I replaced the tools/nbmklocale with the one that was built from
libc sources as part of building the distribution (before the
failure occurs).  Then with -u worked.


Home | Main Index | Thread Index | Old Index