Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Java binaries from this summer loops on current

On Sunday 07 December 2008, Andrew Doran wrote:
> On Thu, Dec 04, 2008 at 12:54:11PM -0700, Sverre Froyen wrote:
> > I've run into what appears to be a lack of backwards compatibility in
> > i386 NetBSD current.
> Between 4.0 and 5.0 the layout of pthread_mutex_t was changed in -current,
> twice.
> The second change was made to restore ABI compatibility between 4.0 and
> 5.0. If you compiled a libary/app that uses libpthread on an earlier
> -current, you need to recompile it again with 4.0, or 5.0, or -current from
> now for it to be compatible with all three.

Thank you.  That explains the problem.  The version that I was using for 
bootstrap was compiled on 28 July -- just before the second change to 
pthread_mutex_t on 2 August.


Home | Main Index | Thread Index | Old Index