Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

strange vnd disk behavior in -current (with ffs2?)


While trying to setup a disk image via vnd0 I ran into the following

1st I've created the disk image file 'temp.disk' on my existing ffs2
partition (softdep mounted):

  dd if=/dev/zero of=temp.disk bs=1 seek=100000000 count=1

-> ls -l temp.disk  
   -rw-r--r--  1 root  wheel  100000001 Oct 30 22:40 temp.disk

Then I

  vnconfig vnd0 temp.disk

and tried to fdisk the vnd0 device:

  fdisk vnd0

On my amd64 machine (4GB RAM) the kernel panics with some kind of
KASSERT (I no longer have a serial console on my new MB :-/, if it's
relevant (and nobody can reproduce it) I can retype it manually).

On a small i386 machine (256 MB RAM) it displays an empty mbr
partition table and 'fdisk -u vnd0' seems to let me edit the partition
table. But after final writing of the new edited partition table, it
will not be stored within the vnd0 disk. A verifying 'fdisk vnd0'
still displays an empty partition table.

So, dd's 'seek=100000000' gap seems to make problems within vnd

Can anybody reproduce this problem with actual -current systems? ...
and other file systems than ffs2?

Is my usage of dd to create a huge and empty disk image file just not



Home | Main Index | Thread Index | Old Index