Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tools error in nbmake

On Fri, Oct 24, 2008 at 09:52:59AM +0200, Alan Barrett wrote:
> On Fri, 24 Oct 2008, David Young wrote:
> > Anyone else seeing the errors at the tail of this build log,
> > <>?  I just
> > updated tonight.  I blew away my objdir and tools directory, and still
> > the errors.
> The errors suggest that the code is trying to us emalloc() and friends,
> but that's not supposed to happen if USE_EMALLOC is not defined, and
> USE_EMALLOC is not supposed to be defined when building the tools
> nbmake.  Is it possible that you have a nonints.h older than revision
> 1.49?

It looks up-to-date:

cuw:~/pristine-nbsd/src> cvs status usr.bin/make/nonints.h
File: nonints.h         Status: Up-to-date

   Working revision:    1.49
   Repository revision: 1.49    /cvsroot/src/usr.bin/make/nonints.h,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      (none)


David Young             OJC Technologies      Urbana, IL * (217) 278-3933 ext 24

Home | Main Index | Thread Index | Old Index