Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

character duplication in X

Running an amd64 kernel from this morning (but an old userland), I'm
having trouble with character duplication when typing in X.  (I haven't
tried it not in X.)  It especially (but not exclusively) happens when
something else is running, such as a -- I'll tap a key and get
(literally) hundreds of characters.  I've seen it most often in my
mailer (claws-mail, which uses gtk2), but I've also seen it in Firefox
and (I think, a few days ago) in xterms.  It makes the system almost
unusable.  Has anyone else seen anything like this?

Many of my tests have been done after suspend/resume tests, since I
wanted to see if an old PR of mine is resolved.  I don't know if that
contributes -- perhaps a timer is not being reinitialized properly?  I
have not yet seen the problem after the latest reboot -- and I haven't
done a suspend/resume.  In fact, I'm typing this right now while
running 'while true; do :; done' in two other windows, with no obvious
problems -- but perhaps I should keep typing to see what happens...

The machine in question is a Thinkpad T61.  I run modular xorg from

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index