Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Trouble sensing NIC on HP Pavillion a6600f

I'll try 4.0

What about the USB interface, it should work in 3.1.1, right?

On Sun, 21 Sep 2008, Bernd Ernesti wrote:

On Sun, Sep 21, 2008 at 01:43:14AM -0400, Yoseff Francus wrote:
I am having a problem seeing either the on-board NIC or a USB (Linksys USB
200M). I am running NetBSD 3.1.1

The message I think is relevant in the logs is

NVIDIA product 0x07dc (ethernet network, revision 0xa2) at pci0 dev 15
function 0 not configured

Looking through some threads I have confirmed that my kernel does have nfe
in it - should take care of the onboard NIC and also has axe in it which
should handle the USB NIC interface.


product NVIDIA  MCP73_LAN1      0x07dc  nForce MCP73 Gigabit Ethernet Controller


date: 2008/02/23 14:21:50;  author: bouyer;  state: Exp;  lines: +58 -14
Pull up following revision(s) (requested by tsutsui in ticket #1061):
       sys/dev/pci/if_nfe.c: revision 1.22, 1.23, 1.25, 1.27
       sys/dev/pci/pcidevs: revision 1.914
       sys/dev/pci/if_nfereg.h: revision 1.5, 1.6
       share/man/man4/nfe.4: revision 1.4
       sys/dev/pci/if_nfevar.h: revision 1.5, 1.6
Add NVIDIA MCP7[37] devices, from OpenBSD.
Attach to NVIDIA MCP67/73 Ethernet controllers.
Add the MCP{67,73} products on nfe_attach().

So it can't be in NetBSD 3.1.1. Support for that deivice is only in -current 
and on
the netbsd-4 branch.

It MAY be enough to add the entry to if_nfe.c, but looking at the changes
it seems you could get problems with power management and I don't know if
there are more problems.


Home | Main Index | Thread Index | Old Index