Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: current userland slapd no response

On Wednesday 17 September 2008 12:01:42 matthew sporleder wrote:
> Okay, I asked in #ldap on freenode and got some good tips.
> Basically, I was wrong.  :)  The undefined error is normal because 0
> is not an error. 

Wow, this was my guess in my other reply :)

> The problem seems to be that ldapsearch closed the
> socket and slapd tried to read it (want 8, got 0), which was the cause
> of that.  This search, apparently, was not a problem other than you
> needing to add -x.

Yep, mentioned this in my other reply too. That was an oversight on my part.

> If you can get this to freeze again, try to let it
> sit (for like a long time) and see if it eventually does close.  I had
> a problem like this on solaris with openldap when I would get into
> swap.  If it never closes (after a few hours, for example), then you
> can try to get the last info from ktruss, slapd -d -1, etc.

As you can see from my previous reply, I can get it to freeze on one request 

Ok, I was kind of hoping the ktruss output in my other reply would be useful 
... but I'll give this a go.

Just remember this worked before a userland update and currently there is no 
load and this is happening (barely any memory being used let alone swap).

Thanks again.


Home | Main Index | Thread Index | Old Index