Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: isp driver on amd64?

Thor Lancelot Simon wrote:
On Tue, Sep 09, 2008 at 10:36:46PM -0400, Thor Lancelot Simon wrote:
I do not have "Enable >4GB addressing" turned on in the adapter BIOS;
I'll try that next.

Well, that caused *a* change.  I don't know if it's a good one.

Now if I do "newfs -I /dev/rsd0d" I get:

isp0: mailbox cmd(0x4005) with no waiters
isp0: I/O while mailbox blocked with retries 66747136

Constantly as newfs runs (very slowly).  If I ^C newfs, the messages
stop; if I restart it, they appear again.

On the other hand, if I do "dd if=/dev/urandom of=/dev/rsd0d bs=64k"
and let it run a while, I can "less -f /dev/rsd0d" and see that, in fact,
the data appear to have been written, with no errors reported -- the
disk is no longer full of NUL.

Does anyone have this driver working on a 64-bit platform?

Hmm. It worked for me on UltraSparc64 and PowerPC and I believe on amd64- I'm pretty sure I tried it in living memory on an amd64/EM64T system. I'll try and fire up a NetBSD amd64. sometime later today or tomorrow and let you know.

The first error you saw:

isp0: bad underrun for 0.0 (count 32768 resid 2147473407, status not marked)
isp0: BOTCHED cmd for 0.0.0 cmd datalen 32768
sd0(isp0:0:0:0): generic HBA error

That's /usually/ a botched target problem. They aren't correctly marking a residual in the FCP response frame. If you're absolutely sure the target is good, you can comment out the check in isp_intr.

It also can be a lost frame problem when going through switches, but that's not the topology you reported.

The second error you saw:

That might be an ACPI/interrupt issue, but I'll have to look at that one more closely.

Home | Main Index | Thread Index | Old Index