Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

problems creating large USB file system

I'm trying to initialize a 500GB external USB hard drive.  Behavior is
quite weird.

My first set of tests was on 4.99.65/i386, with umass0 attaching to an
external USB 2 hub.

I first used fdisk to change from the default FAT32 (!) to NetBSD
(169), and used disklabel to change sd0e from MSDOS to 4.2bsd.  But
newfs has been problematic.

Running it with no options hung after a while:

# newfs sd0e
/dev/rsd0e: 476940.0MB (976773104 sectors) block size 16384, fragment
size 2048 using 2588 cylinder groups of 184.34MB, 11798 blks, 23296
inodes. super-block backups (for fsck_ffs -b #) at:
32, 377568, 755104, 1132640, 1510176, 1887712, 2265248, 2642784,

over the next 45 minutes, it printed


and no more.  I hit ^C; after a bit -- 30 seconds? -- it came back.  I
tried a variety of other options before getting rapid success with

# newfs -b 64k -f 16k -i 256k -O 2 sd0e

I decided to experiment, so I tried some other options, getting the
same long delay.  I then repeated the successful one -- and it hung.
Once, it hung after printing just '256, '.  I've tried several more
times; I still get these mysterious delays, but they've been shorter.
The key point is that the behavior is only loosely correlated with the
options; I get different reactions to the identical command.

I moved the drive to one of the built-in ports on the machine (a Dell
Dimension 8400, if that matters); it didn't help -- I got the same
delays and inconsistent behavior.  Using a port in the back instead of
the front didn't help.

I then moved the drive to a built-in USB port on an 4.99.54/amd64.  No
matter what set of options I specified, it all just worked as expected,
with continuous reasonable progress printing dots.

My suspicion is that I'm seeing some problem at the USB layer, possibly
hardware-specific.  Lights on the indicate that I/O is going on during
the delays.  Any suggestions?

More important, can I trust this drive?  One purpose of it is to hold a
backup of my entire laptop drive while I wipe the disk and reinstall --
Microsoft bugs have trashed the Windows partition...

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index