Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

problems encountered with rum(4)

I recently picked up a D-Link DWL-G122 rev C1 USB (to cover the time
until iwn(4) works).

It loses the network. This seems to become more frequent with
time. Sometimes it loses only the IP address, but ssid and nwkey
settings remain. At other times everything is lost: IP number, ssid,
nwkey. I had initially suspected that this might be related to

and had used the bpf.c patch mentioned in that thread. This did not
solve my problem. I have since disabled wpa_supplicant and this is
happening even with WEP only.

If I reconfigure rum0 and then rerun dhclient every time (I see that)
the network is lost, I have repeatedly been able to completely hang
the system after a number of such losses. In this case dhclient gets
as far as

Jun  2 12:35:13 prpad dhclient: Internet Systems Consortium DHCP Client V3.0.3
Jun  2 12:35:13 prpad dhclient: Copyright 2004-2005 Internet Systems Consortium.
Jun  2 12:35:13 prpad dhclient: All rights reserved.
Jun  2 12:35:13 prpad dhclient: For info, please visit
Jun  2 12:35:13 prpad dhclient: 

and the system does not seem to do anything more, in particular, it
does not react to keyboard input. I have not had the opportunity to
test whether it would still respond to e.g. ping, ssh over ethernet.

Am I missing something? Any hints? Or should I go ahead and enter a

Best regards,


Attachment: pgp2bRXkJ33Wl.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index