Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Unable to boot -current amd64 kernel

Steven M. Bellovin wrote:
On Sat, 03 May 2008 10:26:19 -0400
"Jared D. McNeill" <> wrote:

Andrew Doran wrote:
On Sat, May 03, 2008 at 09:52:57AM -0400, Jared D. McNeill wrote:

I tried booting an i386 -current kernel on the same machine this morning, and it died the same way.
Wow. Willing to do a binary search with cvs co -D? You can also
give -D to "cvs up" so it doesn't mean checking out a full source
tree each time.
The latest locore.S changes is the culprit. Rolling back to the following revisions lets me boot again:

      $NetBSD: locore.S,v 1.42 2008/04/28 20:23:12 martin Exp $
      $NetBSD: pmap.c,v 1.56 2008/04/29 00:44:58 ad Exp $

I'm confident that it's locore as I had previously tried a kernel
with only pmap.c reverted. I rolled back pmap.c to 1.56 to link
against locore 1.42.

On the i386 version, too?

I didn't try, but I assume so -- both locore files should have received the same treatment for bootmod support.


Home | Main Index | Thread Index | Old Index