Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: hang in idle-loop

Christoph Egger wrote:
Andrew Doran wrote:
On Thu, Apr 24, 2008 at 11:10:24PM +0200, Christoph Egger wrote:
Andrew Doran wrote:
On Thu, Apr 24, 2008 at 09:46:33PM +0200, Christoph Egger wrote:

On my AMD Turion X2 Dual-Core, the latest cvs kernel stops booting
after the fsck check.

The CPUs hang in the idle loop, I can break into ddb as much as I want.
More precisely, they hang in x86_stihlt.
Looks like the scheduler don't find a task to schedule?
Can you run with a LOCKDEBUG kernel please? It could be that there is a
scheduler spinlock being leaked somewhere.

Also, what does ps/l show?
I just tried to build a DIAGNOSTIC+DEBUG+LOCKDEBUG kernel and it fails
to link on undefined references to lfs_log, lfs_debug_log, lfs_lognum, etc.

Sounds like a stale build? Try without DEBUG.

Yeah, I removed the amd64/compile/GENERIC directory and build from scratch w/o DEBUG. That build and booted fine.
I also tried w/o DIAGNOSTIC and LOCKDEBUG only and also build and
booted fine.

Is/was this hang in the idle-loop a heisenbug?

I tried a GENERIC kernel w/o DIAGNOSTIC, DEBUG and LOCKDEBUG and it booted fine.

I think, I got bitten by something hidden coming from always building
with -u . The rebuilt from scratch seems to have fixed strange things. I should do that more often. :)

Sorry for the noise.


Home | Main Index | Thread Index | Old Index