Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

usr.bin/passwd compile error

passwd doesn't compile with USE_PAM=no

 cc1: warnings being treated as errors
 src/usr.bin/passwd/krb5_passwd.c: In function 'krb5_chpw':
 src/usr.bin/passwd/krb5_passwd.c:353: warning: 'krb5_free_creds_contents' is 
deprecated (declared at /usr/include/krb5/krb5-protos.h:1623)
 *** Error code 1

Would it be enough to apply the change in rev 1.15 of
src/usr.bin/passwd/krb5_passwd.c also to the non PAM case?


Home | Main Index | Thread Index | Old Index