Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: httpd: _lwp_ctl: Cannot allocate memory

2008/3/14, Sarton O'Brien <>:

> And another, different box/domu but same vintage:
>  Starting Webmin server in /root/webmin-1.310
>  perl: _lwp_ctl: Cannot allocate memory

I see this while configuring perl on sparc64 (Ultra 1, 320MB of RAM,
NetBSD current as of today) -- the reason that I tried to rebuild perl
was that I saw the same message when trying to run the installed perl:

Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)? [ -L/usr/pkg/lib]
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

        cc -o try -O2 -pthread -I/usr/include -fno-strict-aliasing
-pipe -Wdeclaration-after-statement -I/usr/pkg/include -L/usr/pkg/lib
try.c -lm -lcrypt -lpthread

and I got the following output:

try: _lwp_ctl: Cannot allocate memory
The program compiled OK, but exited with status 1.
You have a problem.  Shall I abort Configure [y]
Ok.  Stopping Configure.
*** Error code 1

make: stopped in /home/NetBSD/pkgsrc/lang/perl5
*** Error code 1

- Erik

Home | Main Index | Thread Index | Old Index