Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: src/lib/libpthread changes of 2008-2-10 break pkgsrc/comms/asterisk

Markus W Kilbinger wrote:

After src/lib/pthread changes of 2008-2-10 the unchanged asterisk
package of/on my cobalt qube2/mipsel fails to answer calls and
produces error messages like:

  Feb 15 15:37:34 ERROR[711] chan_sip.c: We could NOT get the channel lock for 
SIP/sipgate-7d999000 - Call ID!
  Feb 15 15:37:34 ERROR[711] chan_sip.c: SIP MESSAGE JUST IGNORED: SIP/2.0
  Feb 15 15:37:34 ERROR[711] chan_sip.c: BAD! BAD! BAD!

Reverting to libpthread based on before 2008-2-10 makes voip calls
handled normally again (and these error messages disappear).

Does anybody directly see what the problem is?
Any more specific info I can provide?

Please send-pr; I'm seeing this too, running my own build of Asterisk 1.6beta2. It worked a-ok before I upgraded yesterday, though I don't have as specific a window of which set of changes killed it. I also rebuilt just to make sure it wasn't something akin to the C++ ABI breakage people have been reporting and see the same problem.

[Feb 22 13:10:32] ERROR[27185] chan_sip.c: We could NOT get the channel lock for SIP/xx-xxxxxx! [Feb 22 13:10:32] ERROR[27185] chan_sip.c: SIP transaction failed:

Looks like I picked the wrong week to stop snifing glue ;)

Home | Main Index | Thread Index | Old Index