Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

mremap, jemalloc, and COMPAT_NETBSD32

   I've been experimenting with running under amd64/current while
chrooted to /emul/netbsd32, which contains an i386/current
distribution. While compiling a package in the chroot, I got a bad
system call from the 32-bit cc1plus. It appears that under some
circumstances jemalloc is calling mremap(2), which isn't supported
   Is this expected to be fixed soon, or should we only expect 4.0
binaries to work for the time being?


                                        Gary Duzan

p.s. I'm compiling my i386/current without jemalloc now to see
     if that gets me past this hurdle.

Home | Main Index | Thread Index | Old Index