tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cpuset_t vs. cpu_set_t

Anthony Mallet <> wrote:
> Hi all,
> I noticed that the recently added sys/pset.h defines a cpuset_t type, and
> the int   pthread_setaffinity_np(pthread_t, size_t, cpuset_t *);
> function.
> On a Linux 2.6, I can find the cpu_set_t type, and
> int pthreadr_setaffinity_np(pthread_t, size_t, cpu_set_t *);
> What is the correct type name? (from a POSIX p.o.v. I mean).

For compatibility purposes we can rename it to cpu_set_t. Anyone see a
potential problem with this?

Best regards,

Home | Main Index | Thread Index | Old Index