tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/mk

[moving to tech-pkg]


On Sat, 7 Mar 2015 18:45:04 +0100
Alistair Crooks <> wrote:

> I wish this had been discussed prior to bringing in - it's an infrastructure
> change, and so would have been nice to talk about various issues I have with this
> when not in reactionary mode.

Fair enough. I did not consider the change to be that major but I
will not recommend it for any more packages until concerns have been

> 1. I like the functionality, HATE the names and the way of doing it
> 2. the GH_* names should be expanded to be GITHUB_*. BUT...

Easily changed, but longer names don't necessarily improve readability
here as it requires an extra tab stop.

> 3.  Why do we have the GH_* defs in the first place if they're
> defaulting to other defs we already have?  They're useless (except
> maybe for GITHUB_COMMIT, but there HAS to be a better name for it than
> that), invade our namespace, and add no value.

We need to be able to override the tag name because sometimes it is
1.0, sometimes v1.0, sometimes something entirely different. See
wip/android-tools-adb for a good example of why all of these are
necessary. There are lots of different styles of naming things on

> 4. USE_GITHUB. "YES". Binary definition. Hate the way this is done.
> Can't we key off MASTER_SITE_GITHUB or similar?

Can you please elaborate with an example?

Kind regards,

Home | Main Index | Thread Index | Old Index