tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with gcc48, plans for gcc49


indeed gcc48 and gcc48-libs are broken on Linux.

On my Ubuntu Linux build hosts, I had to add 
   --disable-libquadmath --disable-libquadmath-support
as configure args to get gcc48-libs to build.

It did not even build on 64bit hosts, and on 32bit hosts the resulting
gcc could not compile (error message about missing crt0 or similar).

Recently tried again on a system without my local patches (the main one
adding "--enable-new-dtags" linker option in addition to "-R", so
LD_LIBRARY_PATH works again), but the build stopped halfways with a
message about missing "strlcmp".

I did not have the time to investigate, but I think there must be some
interference between libtool and the default "-R" (add DT_RUNPATH)
linker setting in mk/compiler/

At least on 32bit hosts, the first few iterations of gcc48 packages
worked. Probably that was before gcc48-libs was required for gcc48. If
gcc48 can be made working again by restoring the previous gcc47-style
that would be a big gain.


Home | Main Index | Thread Index | Old Index