[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: Plan for improving IP_PKTINFO socket option handling
Christos Zoulas <christos%astron.com@localhost> writes:
> This came up in a different discussion; we should pass the size around...
Thanks for fixing that -- and for committings my IP_PKTINFO changes! I
liked the little adjustments you made to the code, there. It does get
more readable with the reduced nesting and early resolution tweaks.
Where can I find official guidelines for coding style?
When we're sure the passing of the buffer size down from getsockopt(2)
is good, we should adjust the bit that handles getting the IP_PKTINFO
option data: the comments are no longer correct, at least.
Most people who graduate with CS degrees don't understand the significance
of Lisp. Lisp is the most important idea in computer science. --Alan Kay
Main Index |
Thread Index |