tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Trouble with networking on Google Compute Engine (NetBSD 7)


I am still trying to get NetBSD 7 running on Google Compute Engine natively. The only remaining issue (AFAICT) is networking.

Here is how the GCE networking works: Each VM in a given project gets a private IP address, for example, with a netmask of The DHCP response contains a „classless static route“ extension (121) to set a direct route to on the same interface. In addition, there is a default route with as gateway.

With -current and dhcpcd (not dhclient), this works fine.

With NetBSD 7 and the dhcpcd there (which AIUI is an older version), I get several error messages (that I forgot to write down) and no working network. wiz@ recommended dhcpcd-6.11.3 from pkgsrc, and that only emits a single error message: „add to routing socket: network is unreachable“ when adding the default route.

I tried adding the routes manually but that gets me the same error message:

route flush
route add -host -interface vioif0
route add default

The last command fails with the „network is unreachable“ message.

I suspect that at this point, I may be running into a kernel bug / limitation that has been fixed in -current. Any ideas? 


Home | Main Index | Thread Index | Old Index