tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot get IPv6 router working

On Wednesday 01 July 2009 00:30:57 Brian A. Seklecki wrote:
> On Tue, 2009-06-30 at 21:10 +0100, Roy Marples wrote:
> > I get an inet6 fe80: address on pppoe0 which indicates IP6CP worked.
> Shouldn't your WAN interface get IP space in 2000::/3 (via NDP or
> PPPoE)?
> FE80::/10 is reserved by IANA for link-local (autoconfig).
> I don't see it being able to actually route.

There is a 2a01 address assigned to the wireless card, it should be able to 
route from there.

> Also, what /64 are you handing out to your ath0/LAN interface?  Are you
> handing it out via rtadvd(8)?  What does rtadvd.conf(5) look like?

rtadvd is handing it out.
I don't use a config - I didn't need to for the previous IPv6 tunnel I ran on 
the same box and I don't see why I should need to now.

And yes, I do have ip6 forwarding enabled in the kernel, ip6mode is set to 



Home | Main Index | Thread Index | Old Index