tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Update, its on NFS only (Re: ffs corruption on 9.66.69 on qemu)

Hi folks,

On Sun, Oct 11, 2020 at 04:10:00PM +0200, Reinoud Zandijk wrote:
> qemu-system-x86_64 -m 4096 -accel nvmm -smp cpus=2 -drive \
>   file=work/wd0.img,format=raw -nographic -gdb tcp::1234 -net nic -net \
>   tap,ifname=tap0,script=no
> Now is this an qemu related problem? I am a bit hessistent to try the -current
> kernel out on real hardware but i've ran a couple minor version on real
> hardware without any issue so far.

I've tried out different combinations and using NVMM or not doesn't make any
difference. Using with wapbl and without doesn't matter.

The image that got corrupted was served over NFS from another NetBSD-9 amd64
machine. When I tried the image locally on FFS the problem disappeared! The
image was modified correctly and got a clean bill of health.

When I see the file opened, the only flags it gives it are O_RDWR | O_CLOEXEC.
Could this interplay with NFS in a different way than with FFS?

Any ideas?

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index