tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Proposal: rename min/max -> umin/umax

I propose we rename libkern's min/max to umin/umax.  The names min and
max invite general use like MIN and MAX, but these functions truncate
their arguments to unsigned first.  We also have imin/imax, lmin/lmax,
and ulmin/ulmax.

This came to my attention while working on a drmkms update, where
Linux's min/max are generic, and a quick grep found, for example:


Home | Main Index | Thread Index | Old Index