Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src/sys



In article <20151130224719.7D1B29A%cvs.netbsd.org@localhost>,
Paul Goyette <source-changes-d%NetBSD.org@localhost> wrote:
>-=-=-=-=-=-

>+	const struct sc_auto *auto_list;
>+	int code;

That should be u_int.

>-			if (module_autoload(syscalls_autoload[i].al_module,
>-			    MODULE_CLASS_ANY) != 0 ||
>+			if (module_autoload(auto_list->al_module,
>+					    MODULE_CLASS_ANY) != 0 ||

KNF.

>+#	autoloadprefix	the prefix for the autoload table name

Why isn't that the emulation name?

>+ * Autoloadable syscall definition
>+ */
>+struct sc_auto {
>+	u_int		al_code;
>+	const char	*al_module;
>+};

A better name would be sc_autoload.

christos



Home | Main Index | Thread Index | Old Index