Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Mopd which works with ELF and a.out in Linux and can netboot ULTRIX

I can't really figure out what you are doing, or where you get into trouble.

I can report that I successfully am booting NetBSD/vax over the network from time to time. In my case a MicroVAX-4000/90, and it is served by a simh VAX-8650 running NetBSD as well. I use this whenever I mess up my boot block or /boot on the 4000. Especially /boot often gets into trouble, as recently built /boot always seem to fail. But I have an older version around, that I fall back to. But in order to fall back, I need to netboot, and then mount the disk and replace /boot.

I think I am using a fairly recent installation system for the netbooting lately.


On 2020-12-24 02:19, Nigel Johnson wrote:
I thought that you may have provided the very last little nugget of
configuration that would get me going, but alas, it still gets a kernel
panic after many thousands of packets have gone across the wire:

[  12.4200070] root on
[  12.4600070] panic: nfs_mountroot: getattr for
[  12.4900070] cpu0: Begin
[  12.5100070] panic: nfs_mountroot: getattr for
[  12.5300070] Stack traceback
[  12.5500070]   Process is executing in user
[  12.5800070] cpu0: End
Stopped in pid 0.1 (system) at  netbsd:vpanic+0x171:    pushl

Any help appreciated!

Merry Christmas, Happy Holidays. Have a cool yule, etc


Amateur Radio, the origin of the open-source concept!
Skype:  TILBURY2591 nw.johnson%ieee.org@localhost

On 2020-12-23 7:50 p.m., Paul Koning wrote:

On Dec 11, 2020, at 1:40 PM, Nigel Johnson <nw.johnson%ieee.org@localhost> wrote:

Thanks to Boris's help below, I now have it booting up to a point.  Wireshark shows 7594 packets to and from the microvax.

I had previously tried all the config files setting suggestions to get NFS to support V2, but found this little gem that solved the problem:

rpc.nfsd 0 && sleep 1           # Stop all previous threads
rpc.nfsd --nfs-version 2,3 8    # Restart 8 threads with versions 2 and 3
I haven't tried these particular things, but recently I was doing some work with the Linux NFS server and found that it supports NFS V2 out of the box.  In fact, that is the default support; V3 and V4 are both optional, interestingly enough.  However, V2 is not enabled by default.  A setting in the [nsfd] section of /etc/nfs.conf takes care of that:


This is also where you can enable NFS over UDP (which also defaults to off).

I verified the V2 support by asking my Mac to mount a Linux NFS volume using V2.  Yes, Mac OS supports V2 in its client, to my great surprise.  Wireshark confirms that it really is using V2.

All this is with a shiny new Linux kernel, 5.8.16, the one that comes with Fedora Core 32.


Johnny Billquist                  || "I'm on a bus
                                  ||  on a psychedelic trip
email: bqt%softjar.se@localhost             ||  Reading murder books
pdp is alive!                     ||  tryin' to stay hip" - B. Idol

Home | Main Index | Thread Index | Old Index