Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Mopd which works with ELF and a.out in Linux and can netboot ULTRIX

> On Dec 11, 2020, at 1:40 PM, Nigel Johnson <nw.johnson%ieee.org@localhost> wrote:
> Thanks to Boris's help below, I now have it booting up to a point.  Wireshark shows 7594 packets to and from the microvax.
> I had previously tried all the config files setting suggestions to get NFS to support V2, but found this little gem that solved the problem:
> rpc.nfsd 0 && sleep 1           # Stop all previous threads
> rpc.nfsd --nfs-version 2,3 8    # Restart 8 threads with versions 2 and 3

I haven't tried these particular things, but recently I was doing some work with the Linux NFS server and found that it supports NFS V2 out of the box.  In fact, that is the default support; V3 and V4 are both optional, interestingly enough.  However, V2 is not enabled by default.  A setting in the [nsfd] section of /etc/nfs.conf takes care of that:


This is also where you can enable NFS over UDP (which also defaults to off).

I verified the V2 support by asking my Mac to mount a Linux NFS volume using V2.  Yes, Mac OS supports V2 in its client, to my great surprise.  Wireshark confirms that it really is using V2.

All this is with a shiny new Linux kernel, 5.8.16, the one that comes with Fedora Core 32.  


Home | Main Index | Thread Index | Old Index