Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Reprogramming FEPROM from the serial port


I'm posting this just in case anyone else runs in to a similar problem. I had the COUGAR.SYS version 1.4 MOP-loadable updater but my system couldn't boot. Here's what I did to flash the FEPROM.

First, I converted COUGAR.SYS into a large text file of 32 bit hexadecimal:

hexdump -v -e '1/4 "%X\n"' COUGAR.SYS > cougar_flash.hex

Next, I ran this little script to take that file and write it properly over the serial port:

read hexbit
echo "d/P/L/U/N:0 1000000 $hexbit"
while read hexbit
  sleep .1
  echo "d/L+$hexbit"

While cu was running using ttyU0, I ran this in another shell:

./write_file < cougar_flash.hex > /dev/ttyU0

I let it run overnight, then, at the chevron prompt, ran:

start 1000200

And it worked! Of course, this hasn't fixed my VAXstation 4000/90, but at least now the system is giving me more meaningful information.


Home | Main Index | Thread Index | Old Index