Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: -current / netbsd-7 kernel hanging

On 12 August 2014 22:04, John Klos <john%ziaspace.com@localhost> wrote:
> Hi,
> I'm trying to boot netbsd-7 from today's sources on a VAXstation 4000/60.
> First, I booted a netbsd-7 kernel compiled from yesterday's sources while
> mounting the existing netbsd-6 userland. I then proceeded to untargzip
> netbsd-7 built sets over the netbsd-6 userland, although it didn't get past
> base.tgz because it started complaining about illegal instructions. I
> finished the upgrade using /rescue/, then rebooted.
> On reboot, it got to:
> root on sd0e dumps on sd0b
> root file system type: ffs
> ...and hung.
> I then set up a MOP server and NFS export, then tried booting a newly built
> kernel:
> boot device: le0
> root on le0
> nfs_boot: trying DHCP/BOOTP
> nfs_boot: DHCP next-server:
> nfs_boot: my_domain=dksdonuts.com
> nfs_boot: my_addr=
> nfs_boot: my_mask=
> nfs_boot: gateway=
> root on
> root file system type: nfs
> ...and it hung. I tried the same thing with a completely GENERIC kernel and
> got the same thing. I then tried the same thing with a -current kernel from
> today's sources, and got the same thing.
> Ideas? Suggestions?

The illegal instructions are somewhat odd - it implies the 7 kernel is
not able to run the 7 binaries. Is it absolutely certain its a 7

An alternate option might be to extract the 7 sets on the server and retest...

Home | Main Index | Thread Index | Old Index