Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Tcl test hangs 5.0_BETA

On Thu, 15 Jan 2009 10:47:18 +0100
Johnny Billquist <bqt%softjar.se@localhost> wrote:

> George Harvey wrote:
> > Hi,
> > 
> > I've built Tcl 8.4.18 from pkgsrc on a 3100/95 running 5.0_BETA. The
> > build completes normally but when I run 'make test' the system hangs
> > when it reaches main.test. There are no error messages but both
> > remote sessions and the local console no longer respond to keyboard
> > input. The system does still reply to pings though, so it's not
> > entirely dead. Is there any way to find out where it has got stuck?
> Break into the debugger, and start poking around.

Tried that and got an unexpected result, after some single-stepping in
the debugger it jumped back to the shell prompt on the console and the
Tcl test, running in an xterm window, woke up, threw an error for the
test that had stuck, and continued on to the end of the run. The error
message is included below. I've got a couple of hundred lines of single
step debugger output as well if anyone wants to have a look at it.


# Error from 'make test TESTFLAGS="-file main.test -verbose t"'
# on Tcl 8.4.19 after a debug session woke it up from a hung state.

---- Tcl_Main-5.2 start

==== Tcl_Main-5.2 Tcl_Main able to handle non-blocking stdin FAILED
---- Result was:
0 {}
---- Result should have been (exact matching):
---- Test cleanup failed:
child killed: trace trap
---- errorInfo(cleanup): child killed: trace trap
    while executing
"close $f"
    ("uplevel" body line 2)
    invoked from within
"uplevel 1 $cleanup"
---- errorCode(cleanup): CHILDKILLED 772 SIGTRAP {trace trap}
==== Tcl_Main-5.2 FAILED

Home | Main Index | Thread Index | Old Index