Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem with Netboot and MicroVax trying to install NetBSD

Ron Olson wrote:
Aloha all-

I have rescued a MicroVAX 3100 from the garbage; it was pulled as a
production machine and still has OpenVMS 6.2 on it. The machine does
boot to VMS and I can log on, do VMS-ish stuff, etc. Of course, what I
really want to do is put NetBSD 4.0 on it. The box is identified as a
KA41-D V1.0 (MicroVAX 3100 M10 KA41-A) that is SCSI based with a tape
drive as its only input source ( i.e. no cd-rom or floppy drives). I
have a thick ethernet-to-rj45 connected on the back and under VMS it
was able to see my home network. Attached to it is a VT420 with a
serial cable that provides the screen and keyboard. It also has two
SCSI disks, a 1 gig and a 2 gig Seagate something-or-other.

Sweet setup!  I am netbooting a MicroVAX 3100 m30, which is very similar.

Okay, so I downloaded and burned the Vax 4.0 ISO to a disc, so far so
good. I also downloaded and built a x86 NetBSD 4.0 machine just for
the purposes of providing a MOPD server so the Vax can net boot and I
can start the installation.  I followed the instructions on the
installation page, whereby a copied BOOT to /tftpboot/mop, renamed the
file MOPBOOT.SYS started mopd as ``mopd -d -a'', then from the >>>
prompt on the Vax typed ``b/100 esa0'', then at the Bootfile: prompt
typed ``mopboot'' whereby on the x86 machine, I see it makes a
connection immediately, but what I get on the screen of the x86
machine is:

MOP RC 802.3 8:0:2b:1d:a:c8 > ab:0:0:2:0:0 len 46 code 07 SID
MOP RC 8:0:2b:1d:a:c8 > ab:0:0:2:0:0 len 37 code 07 SID
MOP DL 802.3 8:0:2b:1d:a:c8 > ab:0:0:1:0:0 len 47 code 08 RPR
MOP DL 8:0:2b:1d:a:c8 > ab:0:0:1:0:0 len 39 code 08 RPR

and then it repeats the third and fourth lines over and over. On the
Vax itself, all I get is ?54 Retry.

I've tried changing the mop filename to the ethernet address, adding
and removing .SYS, tried converting the file to MOP format with
mopcopy, watching the request with tcpdump and moptrace, and I get
nothing more from the vax than ?54 Retry over and over again.

I vaguely recall that I had to use an older version of boot.mop in /tftpboot/mop. At some point mopcopy(1) broke, and I think that broke the build of boot.mop too. Try using boot.mop from 1.6, or even 1.5. If that fails I can send you mine as I know it to be good. Also be sure you are using lower case letters for the hex when you rename boot.mop. Mine looks like this:

-rw-r--r-- 1 hbent users 71168 2005-02-09 12:43 08002b1c9782.SYS

Also, is there any special reason you are using b/100? This may be my ignorance about PROM differences showing, but I just say "b esa0" and everything happens automatically.

Good luck!

-Henry Bent

Home | Main Index | Thread Index | Old Index