Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

sparc wscons behavior in -current and netbsd-6

Returning to this issue with more data.

On Sun, 6 May 2012, John Nemeth wrote:

On Aug 22, 12:26am, "John D. Baker" wrote:
I think someone's clock is off.  My "sent" mailbox shows 6 May 2012.


Booting GENERIC with the stock "/etc/wscons.conf" elicits:

  wsconscfg: WSDISPLAYIO_ADDSCREEN: Device not configured
  wsconscfg: WSDISPLAYIO_ADDSCREEN: Device not configured
  wsconscfg: WSDISPLAYIO_ADDSCREEN: Device not configured

on the console and:

  wsdisplay0: screen 4 added (std, sun emulation)

recorded in 'dmesg'.

While on screen 0, Stop-F2 through Stop-F4 do apparently nothing.  Stop-F5
switches to a blank white screen with a grey cursor in the top-left
corner, presumedly screen 4.  Again, Stop-F2 through Stop-F4 do apparently
nothing and Stop-F1 switches back to the terminal output on screen 0.

Just to see what would happen, I turned on the "screen 5" example in
"wscons.conf" and tried restarting wscons.  I got:

  wsconscfg: screen 4 is already configured

and the "not configured" message for all of the other screens, including
the one I just tried to enable.

Possible clue here:  Instead of screen 5 having a terminal emulation
defined on it, I made a duplicate of screen 4:

  #screen 0       -       vt100
  screen  1       -       vt100
  screen  2       -       vt100
  screen  3       -       vt100
  screen  4       -       -
  screen  5       -       -
  #screen 4       80x25bf vt100
  # Note: You must uncomment the 'font    ibm' line above to get a useful
  #       font for any 50 line screens.
  #screen 5       80x50   vt100

When I restarted wscons,

  wsdisplay0: screen 5 added (std, sun emulation)

was recorded in 'dmesg'  (I otherwise saw no output related to the
creation of screen 5.)  Pressing Stop-F6 switched me to screen 5 (I could
only really tell by the cursor flicker when switching between screens
4 and 5, but it seems to work).

There was the suggestion to build GENERIC with this option added:

# allocate a number of virtual screens at autoconfiguration time

I did so and it does produce the expected 4 terminal screens, although
starting "wscons" produces the following:

  wsconscfg: screen 1 is already configured
  wsconscfg: screen 2 is already configured
  wsconscfg: screen 3 is already configured

init is able to start getty on each one and they seem to work.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index