Port-pmax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Decstation 5000/25 maxine, new RTC startup

This machine has worked fine for years with NetBSD 3.1 and has firmware KNO2-
CA v2.0m.
Since the RTC cell in the Dallas DS1287 was getting low I re-powered it with 
in-situ surgery and a remote 3V cell as many others have done.
It now does not boot firmware to the point where the local console has scan; 
only the initial two flashes appear from the LED and there is no subsequent 
If I remove the cell it will eventually boot to a prompt after about 20 
minutes but gives RTC errors as expected and will not boot the OS.
If I remove the entire RTC it does not boot.
I replaced the DS1287 with a new DS12887, still no boot.

The question I have is this: the data sheet for the DS12887 says that the 
clock in a new chip must be started by writing "a pattern of 010 in bits 4 to 
6 of Register A."  Does this need to be done manually or does the firmware 
automatically do this on boot?

Thanks for reading...

Home | Main Index | Thread Index | Old Index