Port-pmax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: DECstation 2100 floating point

On Sat, 26 Mar 2011 11:53:00 +0900
Izumi Tsutsui <tsutsui%ceres.dti.ne.jp@localhost> wrote:

> As mentioned in gcc(1) man page, -O enables following options:
> >>         -O turns on the following optimization flags: -fdefer-pop
> >>         -fdelayed-branch -fguess-branch-probability -fcprop-registers
> >>         -floop-optimize -fif-conversion -fif-conversion2 -ftree-ccp
> >>         -ftree-dce -ftree-dominator-opts -ftree-dse -ftree-ter -ftree-lrs
> >>         -ftree-sra -ftree-copyrename -ftree-fre -ftree-ch -funit-at-a-time
> >>         -fmerge-constants
> It might help to disable each options (by -fno-delayed-branch etc)
> and which one causes the errors.

I tried turning off each option individually and still got 'inf'
results. I then tried turning them all off, and still got an 'inf'
result. The GCC man page says "only optimizations that have a flag are
listed" so I guess it's one of the unlisted ones that's causing the


Home | Main Index | Thread Index | Old Index