Subject: Re: NetBSD 2.0 installation woes
To: Jurrie Lulofs <>
From: Matt Dainty <>
List: port-hpcmips
Date: 01/20/2005 09:23:50
* Jurrie Lulofs <> [2005-01-20 02:01:23]:
>    I've already done/tried everything that you mentioned.  For network 
> connectivity I used an Edimax-based 10baseT card.  I had no problems 
> configuring the card (I kicked off an FTP based install from the MobilePro 
> using one of the Internet ftp servers; NFS based attempts used a local 
> i386 NetBSD NFS server).  To rule out networking issues I've gone to a 
> local-storage based installation procedure (binary/sets on a CF in a 
> PCMCIA adapter).  My target medium is a 512MB Sandisk CF card.

I tried all of these permutations as well, when trying to install on my

> In all cases I'm able to get the installs kicked off OK (though sometimes 
> after failures I have to newfs the target NetBSD fs using an i386 NetBSD 
> system).  Typically the installation is aborted (and the system is kicked 
> into the debugger) while newfs is running or while the base set is being 
> installed.

This sounds exactly like my problem.

> Haven't you ever seen any "ISA IRQ 3 -> vrgiu0" or "panic: TLB out of
> universe" messages pop up during your installation attempts?
> Frustration is the key sentiment at this time.  The only things I can 
> think of at the moment are to try to install 1.6.1 and/or to try to 
> install the base system on another CF card.
> Any other ideas or words or wisdom would be appreciated.

Yes. Find the patch in the archives in this message;

You will need to most likely rebuild a new release with this patch
added, (rebuilding the 2.0 branch (netbsd-2) worked for me).

This fixed all the panics and random hangs for me.


"Never rub another man's rhubarb."