Subject: Re: PR# install/28656 (Re: new cf-card wont boot)
To: IWAMOTO Toshihiro <>
From: Matthew Orgass <>
List: port-hpcmips
Date: 01/01/2005 12:45:26
On 2005-01-01 wrote:

> At Mon, 20 Dec 2004 22:18:57 +0900 (JST),
> HAMAJIMA Katsuomi wrote:
> > > hase anyone solved the problem?
> > >
> > >> I think this is a know bug, because the same happens to me and others.
> > >> (Sheree Hemphill, Dennis Luxen)
> > >>
> > >> Any regards about how to debug this would be usefull.
> >
> > I received the same problem from hpcmips user, and he sent PR
> > install/28656. This problem occurs with recent CF of high-speed
> > and high-capacity.
> >
> > I found reason of this problem is CF speed-up code(wd.c:1.279),
> > but I cannot fix this problem because I do not have knowledge
> > about ATA.
> sys/arch/hpcarm/hpcarm/softintr.c rev. 1.9 should fix this problem
> (for hpcarm).  I guess hpcmips's problem is also due to some interrupt
> handling bug.

  Yes, this is port-hpcmips/26158.  I found the problem working on the
slhci driver on an early 2.0 branch, but the reason I used the release
branch at the time was that -current would hang mounting root.  That
problem later appeared on the release branch, and though I didn't make the
connection at the time I believe the reason I tried the later release
branch then was for the CF speed up code.

> I imagine this problem happens only with newer CF cards as slower ones
> (like my old 160MB SanDisk) raise interrupts after the interrupt
> handler finishes.

  My card that encounters this problem is claimed to be 224MB and was
purchased when that was about the largest available.  It goes about 3X
faster on my hpcmips machine with the new code.

Matthew Orgass