Port-hpcarm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Odd behavior in some terminal apps.

Tmux cant launch an empty session. It crashes and the terminal needs the reset command to right itself.

Chicken Scheme, bash and other binary packages Ive tried seem fine.

On July 9, 2017 2:43:15 PM EDT, Robert Swindells <rjs%fdy2.co.uk@localhost> wrote:

Wes Fraizer <wes.frazier%members.fsf.org@localhost> wrote:
I am getting segfaults from emacs25 and crashes on launch out of tmux on
my Jornada 720 running NetBSD 7.1. I dont have any any of the X sets
installed and I dont have X installed from pkgsrc im simply trying to
run them from the terminal.

I have tried emacs25 on another StrongARM machine and it crashes for
me too, sorry about that.

With emacs I dont think its running out of memmory or anything. Emacs
reportedly can run on much less.

I'm wondering if this is down to a mismatch in page size between the
build system and the target, newer ARM systems use 8K pages.

I will try rebuilding it on my StrongARM machine, it at least has more
RAM than a Jornada 720.

I have a sneaking suspicion that emacs and tmux both do not like my
terminal somehow. The $TERM variable is set to wsvt25 which should be
fine from what I gather.

Does tmux work with other things ?

Sent from my Android device with K-9 Mail. Please excuse my brevity.

Home | Main Index | Thread Index | Old Index