Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Quartz64 firmware

I wrote:
I spotted that the latest release of the Quartz64 UEFI firmware has a
config option to switch between USB3 and SATA as well as allowing
configuration of the kernel using FDT.

Without changing anything it boots NetBSD fine from USB3.

I seem to be getting a lot of spurious keypresses detected by the
firmware, makes selecting anything in the firmware config menu
difficult. This is with a USB keyboard, can't get serial console
to work.

Retried with r1.1, serial port needed to be 115400 8N1.

Still getting random keypresses with a USB keyboard.

Tried switching the SATA SSD from a USB3 enclosure to power and SATA
cables directly connected to the board.

With SATA selected it just loops back to the config menu.

Booting using SATA has worked a couple of times, out of probably 100 tries.

The times that it did work, at first NetBSD wouldn't detect the SSD, just ahcisata. I copied the wd config line from amd64 and added a "flags 0x0000" option, NetBSD
then detected the drive and booted to multiuser.

  wd* at atabus? drive ? flags 0x0000

Maybe something similar to the "flags 0x0000" option needs to be added to
the firmware to get it to use any device connected to SATA.

Will test out if FDT config works, I'm using a custom kernel that
is stripped down. Having the crypto driver enabled for the RNG would
be good.

Would need device tree sources from a newer Linux release.

Home | Main Index | Thread Index | Old Index