Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Raspberry Pi 3B+ problems: no audio, no multimedia

wiz%NetBSD.org@localhost (Thomas Klausner) writes:

>1. audio does not seem to work. From dmesg:
>audioplay runs for the appropriate amount of time, but I hear nothing.

Maybe it uses a different output, check mixerctl outputs.select.

>2. ld0 throws a lot of errors
>ld0a: error writing fsbn 2214784 of 2214784-2214911 (ld0 bn 2411392; cn 1177 tn 28 sn 0), retrying
>The SD card came new with the Pi. Is it already dying?

Looks like it, but that's just the error ld(4) reports. Do you see
any errors from sdmmc(4) or sdhc(4) ?

>3. omxplayer does not work
>(gdb) bt
>#0  0x7598be84 in _lwp_kill () from /usr/lib/libc.so.12
>#1  0x7598a9e4 in abort () from /usr/lib/libc.so.12
>#2  0x0c7c1320 in sig_handler (s=<optimized out>) at omxplayer.cpp:135
>#3  sig_handler (s=<optimized out>) at omxplayer.cpp:120
>#4  0x7598be8c in _lwp_kill () from /usr/lib/libc.so.12
>Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Did you try other media files?

>4. mpv does not work
>Also tried 9.0 binary package first, then built it myself.
>It segfaults before it plays anything. The backtrace is

Never tried with earmv7hf, but seems to work on aarch64.

Home | Main Index | Thread Index | Old Index