Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: longjmp broken! Postgres fails!

*** Regarding longjmp broken! Postgres fails!; Arthur Hoffmann
*** <hoffmann%it.ntu.edu.au@localhost> adds:

Arthur> Hi I have installed postgres on my NetBSD1.1-amiga.

Arthur> longjmp botch.  Illegal instruction - core dumped initdb:

I have the same problem (also on NetBSD1.1-amiga) with gawk 3.0.0.
However, I'm not sure longjmp() is broken; I did a test program to
check out longjmp() and that program worked fine.  Of course, that
does not prove longjmp() isn't broken, just that it works in some
cases.  I think you may have to search for something that clobbers the
jmp_buf structure passed as an argument to longjmp().  longjmp() must
be used in other code as well, so if longjmp() was broken we should
see longjmp botch in more cases.  The problems I have with gawk 3.0.0
only occur for certain awk programs (like a simple one like `{ next
}'); in fact, all except one of the regression tests work fine.

I haven't had time to make gawk 3.0.0 on another platform to check out
if it is an Amiga NetBSD specific problem.  Has anyone else tried it?

Per Bojsen                                   Email: pb%delta.dk@localhost
DELTA IC Design                                     
Venlighedsvej 4, Hoersholm, Denmark

Home | Main Index | Thread Index | Old Index