Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: TCP problem

> > But the last days I tried to install a slip-connection to a Linux PC
> > without any success. The connection is working perfectly with AmiTCP 
> > 4.0demo,
> > so I know the PC has a correct configuration.
> > I use an A4000/40 with MFCII Card (Port 1)
> ...
> > slattach -s 57600 -dev/ttyM1
>                          ^^^^^
>   Are you using a modem to connect, or is it a direct connection?  If it's
> direct, does the direct connect correctly emulate all modem signals?
>   /dev/ttyM1 is a "modem" connection and will not complete the open process
> until the CD (carrier-detect) signal is received by the serial port.
> Michael
That was a good hint! My nullmodem connector had local crossed RTS/CTS
and DSR/DTR as I use a 20m long 3-wire connection. - I - assumed that would
be enough, as it worked well with AmiTCP.

After some searching in /dev I found some mysterious device ttyA1, which
seemed to be the direct serial device. (why is it named 4A', like seriAl ???)
What is the exact difference between ttyM1 and ttyA1 except the way they
handle the hardware handshake signals ?

A new slattach command started my network, and now its running perfectly !

Thank you very much !

* Manfred Bathelt, Computer Science Student at FAU Erlangen                 *
* Internet:   mdbathel%cip.informatik.uni-erlangen.de@localhost                 
* WWW:        http://wwwcip.informatik.uni-erlangen.de/user/mdbathel        *

Home | Main Index | Thread Index | Old Index