Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [Solved] Re: MPFR

BERTRAND Joël a écrit :
David Brownlee a écrit :
On 29 March 2016 at 14:57, BERTRAND Joël <joel.bertrand%systella.fr@localhost>
David Brownlee a écrit :

On 24 March 2016 at 20:41, BERTRAND Joël <joel.bertrand%systella.fr@localhost>

Bug found. In mk/platform/NetBSD.mk, you have specified for Alpha
CFLAGS=-mieee (line 116). And mpfr cannot be built with this flag.

I think that was added (a long time back :) to help most apps which
expect IEEE754 behaviour to work better on Alpha.

Presumably mpfr used to be able to be built with the flag? I wonder
what changed?

It was. I've used this flag on linux without trouble.

Would that be on AlphaLinux? could it be gcc version related?

     It was on Redhat/alpha and Debian/alpha a long time ago. Maybe with
gcc 3.4. But under NetBSD, I've never have trouble with mpfr (older
version of mpfr and gcc 4.6).

I have seen that mpfr was added in gcc53 sources (provided by pkgsrc
I haven't checked on gnu ftp). gcc53 cannot be built on alpha also.

Thats interesting - I assume some changes must have been made to the
gcc-5.3 imported into tree as NetBSD/alpha cut across to gcc5.3 in the
last day or so, so hopefully the same sort of changes could be applied
to the pkgsrc version...

     To be exact, I don't understand how gcc53 doesn't use pkgsrc/mpfr
and use its own version of mpfr.




Last week, I have upgraded my system to use X on a pm3fb adapter. I'm unable to rebuild mpfr (pkgsrc HEAD up to date) even without -mieee flag in mk/platform/NetBSD.mk :

configure:13829: gcc -o conftest -O2 -mcpu=ev56 -mtune=ev56 -mieee -I/usr/pkg/include -mfp-rounding-mode=d -mieee-with-inexact -I/usr/pkg/include -L/usr/pkg/lib -Wl,-R/usr/pkg/lib conftest.c -lgmp >&5
configure:13829: $? = 0
configure:13829: ./conftest
configure:13829: $? = 191

I have tested with or without -mieee. Always the same result as -mieee-with-inexact is added to command line by configure script itself.

I have deleted -fp-rounding-mode=d -mieee-with-inexact from configure to build mpfr (line 6341) and remove -miee from NetBSD.mk.

	You have to consider mpfr broken.

	Best regards,


Home | Main Index | Thread Index | Old Index