Port-acorn32 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Booting on RiscPC

There are various problems booting on a RiscPC with RISCOS 3.70 with the !BtNetBSD bootloader.

All the BASIC files are, in fact, plain text, not tokenised BASIC files. They do run, but more by luck than judgment :-)

For the record, you can use TEXTLOAD followed by SAVE to get the files in tokenised format. This means that if (when) you get an error, you will at least be able to look at the relevant line number.

Using boot32 fails with Unknown OS_ReadSysInfo call because it's relying on a post-3.7 subcall. I'll look at fixing this.

I tried using BtNetBSD (the BASIC version) by altering the penultimate line in fastboot from:

Set Alias$RunNetBSD <BtNetBSD$Dir>.boot32 <NetBSD$Kernel> <NetBSD$BootOptions>

Set Alias$RunNetBSD <BtNetBSD$Dir>.BtNetBSD <NetBSD$Kernel> <NetBSD$BootOptions>

I needed to alter the screen mode down to something like 800x600 to not get out-of-sync garbase on the screen (I use a custom 1680x1050 mode). I also needed to comment out line 1740 ("SYS "OS_FSControl", 23) because of a non-responding IDE disk on my Simtec podule. The instkern kernel loaded, however it panicked early on:
panic: kernel diagnostic assertion "(ph->ph_nmissing < pp->pr_itemsperpage)" failed: file "/usr/src/sys/kern/subr_pool.c", line 893 pool_get: kmem-32: page empty

The keyboard is also completely messed up at this point, so you can't type anything.

I tried other kernel versions with slightly more success, but keyboard problems have been around for a long time:

3.1 - booted, keyboard works
4.0.1 - fails to boot (kernel loads, but nothing happens)
5.2.3 - booted, but no keyboard
6.1.5 - booted, but no keyboard
netbsd-7 - booted, but no keyboard
netbsd-8 - booted, but no keyboard
-current - booted, but panic after:

[   1.0000200] clock: hz=100 stathz = 0 profhz = 0
[   1.0000200] WARNING: delay(10000) took 0us
[ 4294967296.7] panic: divide by 0

Yes, the instkern included with BtNetBSD.spk gives different results to a netbsd-INSTALL.gz kernel from the same build.

(also, grrr, no support for I-Cubed EtherH cards).

dmesg for 3.1 here:


Home | Main Index | Thread Index | Old Index