pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: sysutils/gvfs fails to build

"David H. Gutteridge" <> writes:

> On Thu, 28 Apr 2022 at 08:30:31 -0400, Greg Troxel wrote:
>> netbsd-9, up-to-date pkgsrc-current.
>> It is complaining about the fuse version being old:
>>  checking for FUSE... no
>>  configure: error: Package requirements (fuse >= 2.8.0) were not met:
>>  Package dependency requirement 'fuse >= 2.8.0' could not be satisfied.
>>  Package 'fuse' has version '2.6.0', required version is '>= 2.8.0'
>> and I happen to have fuse 2.9.3, but I think is
>> selecting the builtin fuse.
>> I am guessing this is fallout from some recent change, but I'm curious
>> if others see it too.
> Yes, I'm seeing it too, and it appears in mef@'s latest bulk build
> report:
> Until last week, fuse wasn't a default-on option for NetBSD in gvfs,
> but someone changed that, so now it fails to build, given the buildlink
> issue you noted. (This in turn causes the Xfce4 meta-pkgs to fail to
> build, since Thunar and related plugins still have dependencies on gvfs
> for particular bits.)

nia@ has just worked around this; fuse is now default on NetBSD only on

(I suspect there is still a bug in the fuse bl3.)

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index