pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

X11_TYPE=native problems with updated XQuartz


   As posted on the pkgsrc channel on Matrix:

I just upgraded XQuartz and tried to rebuild all my packages (X11_TYPE=native), but am encountering:

   ERROR: This package has set PKG_FAIL_REASON:
ERROR: /opt/X11: X11_TYPE=native but xbase set is not installed (missing: makedepend). Either set X11_TYPE to modular or install xbase.

This is on macOS Big Sur (x86_64), updated pkgsrc minutes ago. I tried installing devel/makedepend manually, but this didn't help. (I assume it's because native is hardcoded to look for it in /opt/X11).

Never seen this one before -- I assume they decided to change something in XQuartz 2.8.1 which breaks pkgsrc's assumptions.

Unsurprisingly, setting X11_TYPE=modular works, but (also unsurprisingly) adds a significant amount of build time.

Kind regards,
Jan Danielsson

Home | Main Index | Thread Index | Old Index