pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: math/blas not compiling due to gcc7 error

On Wed, Feb 10, 2021 at 11:43 AM Connor McLaughlan <> wrote:

On Tue, Aug 25, 2020 at 12:39 AM Chavdar Ivanov <> wrote:

> In any case, could you please check with nm if has "cabsl"?

~~ nm /lib/ |grep cab
000000000000d516 T __c99_cabs
000000000000d4ff T __c99_cabsf
000000000001957b T __c99_cabsl
000000000000d52d T cabs
000000000000d51b T cabsf

so, no.

> Still trying to figure out if it is a problem of the base system or
> the gfortran configuration.
> But those things linking and symbol things are not exactly my
> expertise, so i'm just trying around.
> I also tried gcc8 gfortran by setting it in mk.conf and compiling
> math/blas as suggested.
> gcc8  gets installed and applied, but yields the same cabsl problem again:
> bash-5.0# bmake install
> => Bootstrap dependency digest>=20010302: found digest-20190127
> => Checksum SHA1 OK for lapack-3.9.0.tgz
> => Checksum RMD160 OK for lapack-3.9.0.tgz
> => Checksum SHA512 OK for lapack-3.9.0.tgz
> ===> Installing dependencies for blas-3.9.0
> => Tool dependency bsdtar-[0-9]*: found bsdtar-3.4.3
> => Tool dependency cmake>=2.8.1nb1: found cmake-3.17.3

FWIW my cmake is 3.18.1.

I have set up a new system on an empty SSD: NetBSD9.1, latest pkgsrc, sparc64.
The problem is still present and blas-3.9.0 / lapack-3.9.0 will not compile.

I tried to compile the old blas-3.7.1nb1 / lapack-3.7.1nb1 and it will finish without a problem.

The main difference is that the old versions use gmake, while the new version use cmake (i am using cmake 3.19.2).

Any ideas if that could be the cause?

Ok this was premature...i can compile the old gmake based versions, but upon running i end up again with the problem that cabsl is missing in

   /usr/bin/ld: /usr/pkg/gcc7/lib/gcc/sparc64--netbsd/7.5.0/../../../ undefined reference to `cabsl'

Don't really know how interpret it and if it is a problem in the base libraries of the system or in the pkgsrc created gcc-7.5.0.


Home | Main Index | Thread Index | Old Index