pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with bootstraping for OpenServer 5 and pkgsrc-2019Q4

Hello All,

I'm in the pkgsrc-2019Q4 bootsrap directoy. I successfully did a bootstrap with the pkgsrc-2015Q1 source. I can't do a bootstrap with the pkgsrc-2019Q4 source. I'm running into the error.

# pwd

I run this command in the bootstrap directory
./bootstrap --prefer-pkgsrc yes

On Wednesday 2020-02-26 21:42, Roland Illig wrote:

On 26.02.2020 16:43, Boyd Lynn Gerber wrote:

I'm able to boostrap from pkgsrc-2015Q1, but I'm hitting this issue with the pkgsrc-2019Q4 and

The subject line says 2019Q4, here you say 2015Q1. Which is it?

The 2019Q4.  There is no issue doing a bootstrap with 2015Q1.

 I'm not sure how to deal with it.  I have the following set

Before posting any command outputs, you should generally say which
commands you ran, and in which environment. In this case it's relatively
easy to guess what you did, based on the output. It was probably:

cd /u/build/pkgsrc-blg/archivers/pax
bmake update  # or install, who knows

I wish I was that far.  It is the initial bootstrap being done as root

cd /u/build/pkgsrc-blg/bootstrap/
./bootstrap --prefer-pkgsrc yes

 /u/build/pkgsrc-blg/bootstrap/work/bin/install-sh -c -o root -g sys -m
 444 tar.1
 tar | sed 's&^&nb&').1
=>  Automatic manual page handling
=>  Generating post-install file lists
=>  Checking file-check results for pax-20080110nb4
 /bin/sh: -u:  not found
 /bin/sh: -u:  not found
 /bin/sh: -u:  not found
 /bin/sh: -u:  not found

To further investigate this problem yourself, you should run the command
again, this time with a bit more debug information:

I do not see a debug option with bootstrap.

./bootstrap --help
===> bootstrap started: Wed Feb 26 15:02:20 MST 2020
Usage: ./bootstrap
    [ --abi [32|64] ]
    [ --binary-kit <tarball> ]
    [ --binary-macpkg <pkg> ]
    [ --compiler <compiler> ]
    [ --cwrappers <auto|yes|no> ]
    [ --full ]
    [ --gzip-binary-kit <tarball> ]
    [ --help ]
    [ --make-jobs <num> ]
    [ --mk-fragment <mk.conf> ]
    [ --pkgdbdir <pkgdbdir> ]
    [ --pkginfodir <pkginfodir> ]
    [ --pkgmandir <pkgmandir> ]
    [ --prefer-pkgsrc <list|yes|no> ]
    [ --prefix <prefix> ]
    [ --preserve-path ]
    [ --quiet ]
    [ --sysconfdir <sysconfdir> ]
    [ --unprivileged | --ignore-user-check ]
    [ --varbase <varbase> ]
    [ --workdir <workdir> ]

Oh, that file even says:

# /bin/diff under OpenServer 5.0.7/3.2 does not support -u option.
# TOOLS_PLATFORM.diff?=		/bin/diff

The system comes with diff in /usr/gnu/bin/diff

diff --version
diff (GNU diffutils) 2.8.1
gdiff --version
diff (GNU diffutils) 2.8.1
id --version
id (GNU coreutils) 6.7

I just built diffutils-3.3
diff --version
diff (GNU diffutils) 3.3

I've tried with both /bin/ksh, /bin/sh linked to /bin/ksh, and /usr/bin/bash.

env shows I have

I have tried both upon login modifying /etc/passwd

my man on ksh shows

   -u file
          True, if file exists and has its setuid bit set.

I've even linked /bin/sh -> /bin/ksh

Does this mean the file doesn't exist?

I'm still getting the error.

This means you have to build a diff tool first. Since all other
platforms have "diff -u", this is not checked by the pkgsrc bootstrap.

diff --help
-u -U NUM --unified[=NUM] Output NUM (default 3) lines of unified context.
    --label LABEL  Use LABEL instead of file name.
    -p  --show-c-function  Show which C function each change is in.
-F RE --show-function-line=RE Show the most recent line matching RE.

Any other ideas?


Boyd Gerber <> 801 849-0213
ZENEZ   1042 East Fort Union #135, Midvale Utah  84047

Home | Main Index | Thread Index | Old Index