pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wxGTK28 vs. wxGTK30

On Mon, 25 Nov 2019 at 16:08, Thomas Klausner <> wrote:
> On Mon, Nov 25, 2019 at 03:15:26PM +0000, Chavdar Ivanov wrote:
> > Hi,
> >
> > wxmaxima now uses wxGTK30, however, if one has wxGTK28 installed in
> > the build host, cmake makes a mess of it including bits from wxGTK28.
> > I tried to patch the initial CMake file to have wxGTK30 as the minimum
> > version accepted, it did not make a difference, the bits from wxGTK28
> > were still included.
> >
> > The problem goes away if one uninstalls wxGTK28 from the build host,
> > then wxmaxima builds right away.
> >
> > On my build host the only reason I had wxGTK28 installed was
> > graphics/wxsvg package, which builds correctly if one replaces the
> > include in the Makefile:
> > ...
> > -.include "../../x11/wxGTK28/"
> > +.include "../../x11/wxGTK30/"
> > ...
> Then probably multimedia/dvdstyler, the only consumer of the library,
> will break, since it still depends on wxGTK28.
> There is a newer version out (3.1), care to update to it and switch it
> to wxGTK30? I guess that's the reason you have wxSVG installed.

The reason I've got wxsvg installed has been irretrivably lost in the
past... I haven't used dvdstyler as well, but decided to see if it is
not too hard to sort out.

It turned out it needs newer version of wxsvg than we have (it needs
at least 1.5.12, we have 1.5.3). I tried the latest - 1.5.20;
initially had some problem with libexif, which I sorted out somehow
(created the missing links in the .buildlink directry....), but later
I stuck a problem with ffmpeg:
libtool: compile:  c++ -DPACKAGE_NAME=\"wxsvg\"
"-DPACKAGE_STRING=\"wxsvg 1.5.20\"" -DPACKAGE_B
-DPACKAGE=\"wxsvg\" -DVERSION=\"1.5.20\" -DSTDC_HEADERS=1
=1 -DLT_OBJDIR=\".libs/\" -I. -I../include -I../include/wxSVG
-I/usr/pkgsrc/graphics/wxsvg/work/.buildlink/include/wx-3.0 -I/us
clude -O2 -I/usr/pkgsrc/graphics/wxsvg/work/.buildlink/include/cairo
/include/fribidi -D_REENTRANT
__ -pthread -DUSE_LIBAV -MT mediadec_ffmpeg.lo -MD -MP -MF
.deps/mediadec_ffmpeg.Tpo -c mediadec_ffmpeg.cpp  -fPIC -DPIC -o
mediadec_ffmpeg.cpp: In member function 'virtual float
mediadec_ffmpeg.cpp:116:2: error: 'AVCodecParameters' was not declared
in this scope
  AVCodecParameters *enc = st->codecpar;
mediadec_ffmpeg.cpp:116:2: note: suggested alternative: 'AVCodecParser'
  AVCodecParameters *enc = st->codecpar;
mediadec_ffmpeg.cpp:116:21: error: 'enc' was not declared in this scope
  AVCodecParameters *enc = st->codecpar;


which is beyond me....


>  Thomas


Home | Main Index | Thread Index | Old Index