pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pbulk : don't know how to make /nonexistent

I dug dug dug and dug again to find the root of the problem but I couldn't find anything usefull.
I tried to had some trace in pbulk/libexec/pbulk/pkg-build in run_make() function. :

run_make() {
        local run_cmd
        date >> /root/pbulk-trace.txt
        echo run-make >> /root/pbulk-trace.txt
        pwd >> /root/pbulk-trace.txt
        echo ${run_cmd} ${make} "$@" BATCH=1 DEPENDS_TARGET=/nonexistent ${MAKE_FLAGS} WRKL
OG=${bulklog}/${pkgname}/work.log >> /root/pbulk-trace.txt
        #END TRACE
        ${run_cmd} ${make} "$@" \
                BATCH=1 \
                DEPENDS_TARGET=/nonexistent \
                ${MAKE_FLAGS} \

And in run_su function :

run_su() {
date >> /root/pbulk-trace.txt
echo run_su >> /root/pbulk-trace.txt
echo su ${unprivileged_user} -c '"$@"' make "$@" >> /root/pbulk-trace.txt
su ${unprivileged_user} -c '"$@"' make "$@";

That permitted me to see only 2 "commands" were executed :

/usr/pkg/bin/bmake checksum BATCH=1 DEPENDS_TARGET=/nonexistent WRKLOG=/srv/data/log/pbulk/fetch-1.8nb3/work.log
su pbulk -c "$@" make /usr/pkg/bin/bmake configure BATCH=1 DEPENDS_TARGET=/nonexistent WRKLOG=/srv/data/log/pbulk/fetch-1.8nb3/work.log

I tried to reproduce the "bmake[1]: don't know how to make /nonexistent. Stop" error maually to see if I can get more output. I ran a "make clean clean-depends" in pkgsrc/net/fetch and to be sure nothing was remaining I wiped anything in WRKOBJDIR.Running those command does compile libfetch but fails later :

===> Building binary package for libfetch-2.38
=> Creating binary package /srv/data/packages/All/libfetch-2.38.tgz
=> Becoming ``root'' to make su-real-package-install (/usr/bin/su)
su: You are not listed in the correct secondary group (wheel) to su root.
su: Sorry: Authentication error
*** Error code 1

Don't forget we're running as pbulk user who should be an "unprivileged user". That would be a little weird to give root access to a unprivileged user... Am I missing something ? And by the way, why am I getting 2 different behaviors when running bulkbuild vs these 2 commands ?

On Mon, Nov 5, 2018 at 6:08 PM Julien Savard <> wrote:
I tried to change the 'make' used :


I also removed all packages already compiled in PACKAGE ( in my case /srv/data/packages). Now it fails even sooner :

Initialisation complete.
[1/10] Starting build of  cwrappers-20180325
[1/10] Successfully built cwrappers-20180325
[2/10] Starting build of  libfetch-2.38
[2/10] Successfully built libfetch-2.38
[3/10] Starting build of  digest-20160304
[3/10] Successfully built digest-20160304
[4/10] Starting build of  fetch-1.8nb3
[4/10] Failed to build    fetch-1.8nb3

fetch is a prerequisite in my mk.conf ( FETCH_USING=fetch).

Interesting fact : When I compile, for instance, libfetch within pkgsrc ( whitout pbulk : cd /srv/pkgsrc/; /usr/pkg/bin/bmake pacakge or make package ), it does work.

nbqc1-osparc6# head -2 /root/nohup.out
===> Installing dependencies for libfetch-2.38
nbqc1-osparc6# tail -2 /root/nohup.out
===> Building binary package for libfetch-2.38
=> Creating binary package /srv/data/packages/All/libfetch-2.38.tgz

I guess it must be something in my pbulk.conf. If it were in my mk.conf I wouldn't be able to compile it outside of bulkbuild.

On Mon, Nov 5, 2018 at 6:06 AM Joerg Sonnenberger <> wrote:
On Sun, Nov 04, 2018 at 07:17:06PM -0500, Julien Savard wrote:
> Hi,
> here is the make I use in pbulk.conf :
> nbqc1-osparc6$ grep make= /srv/pbulk/etc/pbulk.conf
> make=${prefix}/bin/bmake
> Should I use the make outside $prefix (/usr/bin/make) ?

Yes, it should be the make used by the regular build.


Home | Main Index | Thread Index | Old Index