pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Newly updated modular Xorg won't start

On 07/05, Thomas Mueller wrote:
> I don't really know what to quote here, but I tried some of the suggestions.
> "Xorg -retro" as root had the same unsuccessful outcome.
> To avoid moving a lot of stuff, which might be error-prone, I tried 
> startx -- -config xorg.conf.null   and
> startx /usr/pkg/etc/X11/xinit/xinitrc.icewm -- -config xorg.conf.null
> where xorg.conf.null is a zero-byte file.
> Result was the same.

I'm not an Xorg expert, but I think specifying "-config xorg.conf.null"
will just add that empty file to the list of configuration files
considered; it will have the highest precedence, but it won't make
Xorg not read the other ones, and since it's empty, the behavior won't

Maybe you could try "Xorg -configure" as root to generate a new
configuration file and then use it as root with "Xorg -config
$HOME/" or similar?  Or maybe you could really move your
existing xorg.conf out of the way temporarily?



Home | Main Index | Thread Index | Old Index